N2920 USB 3.0 working as 2.0

If you need help for mini pc please post and discuss here

Moderator: kevinchen

Forum rules
Please do not post any SPAM!
Posts: 1
Joined: Mon Mar 14, 2016 7:42 am

N2920 USB 3.0 working as 2.0

Postby malow » Mon Mar 14, 2016 10:25 am

hi, i have a hystou fanless minipc with celeron N2920. all works great, but i got a big problem on the USB 3.0 port (it has one 3.0).

the USB 3.0 uses a intel driver, and after installing the driver from intel site, the usb 3.0 port (the blue one) works as 2.0. if i plug a usb 3.0 hard drive, or a usb 3.0 card reader, it says that this device can perform faster if plugged on a usb 3.0 port. (but is already on the usb 3.0 port)

using software like USB Tree View to see the usb ports, the usb 3.0 port is under the 2.0 hub in the 3.0 host. and some 2.0 ports are inside the 3.0 host.

so, basically, the ports are "scrambled". some 2.0 ports are on the 3.0 hub, but of course works only as 2.0. and the only 3.0 port is inside the 2.0 hub, so will not works as 3.0.

i read on forum that the driver will "allocate" the ports and arrange them correctly when the drive is loaded, but its not my case.

so, my question: this mini-pc have a special driver that correctly maps the ports? cause the intel and others i tried, all result in the same behavior, the ports are assigned wrongly.

im using win7 x64. already tried win10 x64, and the problems is the same.

User avatar
Posts: 85
Joined: Thu Jan 07, 2016 1:16 am
Location: Shenzhen, China

Re: N2920 USB 3.0 working as 2.0

Postby kevinchen » Sat Mar 19, 2016 9:03 am

you may install wrong drivers my friend, install 3.0 driver not 2.0 from intel, thank you.
Hystou factory Tech Support
Core i5-4200U | Core i7-4500U | Core i5-5257U | Core i7-5500U | Fanless Laptop

Return to “Asking For Help”

Who is online

Users browsing this forum: No registered users and 1 guest